Credit Handout Delay

Incident Report for Virtuagym

Resolved

This incident has been resolved.
Posted Feb 11, 2025 - 10:25 UTC

Investigating

Due to a technical issue, credit handouts for a small number of clubs are currently experiencing delays. Our team is actively working to resolve this, and we expect normal operations to resume shortly.

We apologize for any inconvenience and appreciate your understanding.
Posted Feb 05, 2025 - 09:18 UTC
This incident affected: Website.