Some services are showing decreased performance.
Incident Report for Virtuagym
Resolved
This incident has been resolved.
Posted Feb 24, 2023 - 10:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results. We appreciate your patience and understanding!
Posted Feb 24, 2023 - 09:56 UTC
Identified
The system is particularly vulnerable when multiple cronjobs are running at the same time. We use cronjobs to have the system schedule certain tasks, and try to avoid too many of these happening at the same time. Whilst we prevent that from happening, today the situation was aggravated by the execution of Semrushbot: a bot which is automatically clicking on every possible link on the old schedule, causing a denial of service on our platform - leading to the system being unavailable across web and apps. We are currently blocking this bots range of IP addresses as a first containment measure, and returning to normal service levels.
Posted Feb 24, 2023 - 09:55 UTC
Investigating
We are currently investigating an issue and working to resolve it as soon as possible. We apologize for any inconvenience this may cause and appreciate your patience. We will provide an update within 30 minutes to keep you informed on the progress of the resolution.
Posted Feb 24, 2023 - 09:30 UTC
This incident affected: Website, Mobile Apps, and API.